Minimum system requirement

For the best Countr POS app experience, we recommend to use iPad with iOS 9.3.5 or above. However, the latest iOS is always preferred.  

Download via Apple App Store

You can download Countr POS app from the Apple App Store on your iPad or iPhone or simply type in "Countr POS" in the search box

Did this answer your question?